Aprés une mise à jour (principalement kde) j'ai eu ce message lorsque j'ai voulu lancer skrooge (application de gestion de finances personnelles) :

-##WARNING: QSocketNotifier: Invalid socket 8 and type 'Read', disabling

 

Skrooge refusait de se lancer, quelques recherches sur internet et pas vraiment de réponses satisfaisantes, finalement j'ai lancé une compilation de skrooge avec la commande suivante (et en root)

FEATURES="-getbinpkg" emerge -avq skrooge

et 3 minutes plus tard skrooge redevenait opérationnel.